vendredi 22 avril 2016

ASP.NET Framework 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 - l'enfer du DotNET

Vous comprenez toutes ces versions du .NET Framework ? Moi pas encore. Alors essayons de découvrir ce qu'il se cache derrière tout ça.

https://msdn.microsoft.com/fr-fr/library/w0x726c2(v=vs.110).aspx
.NET Framework 4.6 et 4.5

http://getdotnet.azurewebsites.net/target-dotnet-platforms.html
A lire absolument, les versions du DotNET sont associées et expliquées avec celles de Visual Studio.

Problème et symptômes

Depuis peu j'ai des soucis avec mon Visual Studio 2013 et la mise à jour Service Pack 4. Je désinstalle les mises à jour, le SP4. Je réinstalle mon Visual Studio 2013 à partir du DVD d'installe.

Et boom !
ASP.NET 4.5 n'est pas enregistré sur le serveur Web.
Je tente un coups de :
C:\Windows\Microsoft.NET\Framework\v4.0.30319>aspnet_regiis -i puis avec l'option -ir.

Rien n'y fait ! Entre temps, je pense que les mise à jours de Windows avaient installées le Framework 4.6.1 et que mon Visual Studio 2013 n'est pas compatible avec cette version sans le SP4 !

Bienvenu dans l'enfer du DotNET !

Recherche d'une solution

Je regarde dans les programme installé, j'ai le Framework 4.5.2 :

Les différentes version du framework .NET, c'est lenfer !
Ah bon le 4.5.2 ? Moi je croyais que j'étais resté au 4.5... bref ça ne marche pas !

Sur cette machine, il y a aussi le 4.6.1 d'installé :

Framework 4.6.1
Je ne me dégonfle pas, je vire tout ça !
Par curiosité, je regarde dans le répertoire C:\Windows\Microsoft.NET\Framework\v4.0.30319,

Voici ce que j'y vois :

Framework 4.0.30319
Après ces désinstallations successives, je pensais que j'allais retrouver un FrameWork 4.5 ou 4.5.1 mais quand je vois le tête du répertoire 4.0.30319, une chose est sûr, ça va beaucoup moins bien marché maintenant ;-)

Pendant ce temps, évidemment, mon processus de mise à jour Windows Update est dans les choux complet depuis quelques heures...

Je pars chercher une solution et je reviens ...

Un peu de littérature :
https://blogs.msdn.microsoft.com/dotnet/2015/12/09/support-ending-for-the-net-framework-4-4-5-and-4-5-1/

Ça déprime un peu ! Ça pique même un peu également. Je crois que je vais choisir un des liens d'installation du 4.5.2 qui m'à l'air d'être supporté... par Windows et par Visual Studio à la fois.

https://www.microsoft.com/fr-FR/download/confirmation.aspx?id=42642
Installation de Microsoft.NET Framework 4.5.2

Bienvenu dans l'enfer du DotNET !

Allez une petite dernière pour la fin :

Mise à jour cliquez sur Oui
Voilà, malgré tout, ça fonctionne quand même, c'est du bidouillage le problème c'est que l'on a rien appris sur les différents frameworks et les différentes versions et que comme professionnel, je n'ai pas de temps à perdre avec tout ça !

Have fun!

Aucun commentaire:

Publier un commentaire